blob: c3d51282c2e28815582bcb41151ea72ccc228c15 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A lil' TOML parser"
2DESCRIPTION = "Tomli is a Python library for parsing TOML. Tomli is fully \
3compatible with TOML v1.0.0."
4HOMEPAGE = "https://github.com/hukkin/tomli"
5BUGTRACKER = "https://github.com/hukkin/tomli/issues"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "de526c12914f0c550d15924c62d72abc48d6fe7364aa87328337a31007fe8a4f"
12
13do_configure:prepend() {
14cat > ${S}/setup.py <<-EOF
15from setuptools import setup
16setup(name="tomli", version="${PV}", packages=["tomli"], package_dir={'tomli': 'src/tomli'}, package_data={"": ["*"]})
17EOF
18}
19
20BBCLASSEXTEND = "native nativesdk"