blob: 34bf2550f56f808b3932d13d9c0d128ea48056f8 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Tool for creating HTML, PDF, EPUB, man pages"
2DESCRIPTION = "AsciiDoc is a text document format for writing short documents, \
3articles, books and UNIX man pages."
4
5HOMEPAGE = "http://asciidoc.org/"
6
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=4e5d1baf6f20559e3bec172226a47e4e \
9 file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 "
10
11SRC_URI = "git://github.com/asciidoc/asciidoc-py3;protocol=https;branch=main"
12SRCREV = "342639edbbc0dcc64354a0291d2214d4d5e65cab"
13
14DEPENDS = "libxml2-native libxslt-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
15
16S = "${WORKDIR}/git"
17
18# Tell xmllint where to find the DocBook XML catalogue, because right now it
19# opens /etc/xml/catalog on the host. Depends on auto-catalogs.patch
20export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
21
22inherit setuptools3
23PIP_INSTALL_PACKAGE = "asciidoc"
24CLEANBROKEN = "1"
25
26BBCLASSEXTEND = "native nativesdk"
27
28UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))$"