blob: e1548df15f00a34dbf415a3c434b979379f61fc1 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Line-oriented text editor"
2HOMEPAGE = "http://www.gnu.org/software/ed/"
3DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands."
4
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
7 file://ed.h;endline=20;md5=6e6a818b0593f937fc63ba08d5e314bf \
8 file://main.c;endline=17;md5=8419a08bb12936f32384a0d1c0f9e74c \
9 "
10
11SECTION = "base"
12
13CVE_PRODUCT = "gnu:ed"
14
15# LSB states that ed should be in /bin/
16bindir = "${base_bindir}"
17
18# Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/
19SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz"
20UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/"
21
22SRC_URI[sha256sum] = "aca8efad9800c587724a20b97aa8fc47e6b5a47df81606feaba831b074462b4f"
23
24EXTRA_OEMAKE = "-e MAKEFLAGS="
25
26inherit texinfo
27
28do_configure() {
29 ${S}/configure
30}
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34 # Info dir listing isn't interesting at this point so remove it if it exists.
35 if [ -e "${D}${infodir}/dir" ]; then
36 rm -f ${D}${infodir}/dir
37 fi
38}