blob: cff4ed17172614460936e690fa1070fc881d9fd4 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001require gzip.inc
2
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003LICENSE = "GPL-3.0-or-later"
Andrew Geisslereff27472021-10-29 15:35:00 -05004
5SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz \
6 file://run-ptest \
7 "
8SRC_URI:append:class-target = " file://wrong-path-fix.patch"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
11 file://gzip.h;beginline=8;endline=20;md5=6e47caaa630e0c8bf9f1bc8d94a8ed0e"
12
13PROVIDES:append:class-native = " gzip-replacement-native"
14
15RDEPENDS:${PN}-ptest += "make perl grep diffutils"
16
17BBCLASSEXTEND = "native nativesdk"
18
19inherit ptest
20
21do_install_ptest() {
22 mkdir -p ${D}${PTEST_PATH}/src/build-aux
23 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/src/build-aux/
24 mkdir -p ${D}${PTEST_PATH}/src/tests
25 cp -r ${S}/tests/* ${D}${PTEST_PATH}/src/tests
26 sed -e 's/^abs_srcdir = ..*/abs_srcdir = \.\./' \
27 -e 's/^top_srcdir = ..*/top_srcdir = \.\./' \
28 -e 's/^GREP = ..*/GREP = grep/' \
29 -e 's/^AWK = ..*/AWK = awk/' \
30 -e 's/^srcdir = ..*/srcdir = \./' \
31 -e 's/^Makefile: ..*/Makefile: /' \
32 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
33 -e 's|${DEBUG_PREFIX_MAP}||g' \
34 -e 's:${HOSTTOOLS_DIR}/::g' \
35 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
36 ${B}/tests/Makefile > ${D}${PTEST_PATH}/src/tests/Makefile
37}
38
39SRC_URI[sha256sum] = "3e8a0e0c45bad3009341dce17d71536c4c655d9313039021ce7554a26cd50ed9"