blob: 2bc035a538d61d2f512491ff30c62c3c017923b8 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "Small image capable of booting a device with custom install scripts, \
2adding a second rootfs, used for testing."
3
4# use -testfs live-install scripts
5PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install-testfs initramfs-live-install-efi-testfs busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
6
7# Do not pollute the initrd image with rootfs features
8IMAGE_FEATURES = ""
9
10export IMAGE_BASENAME = "core-image-testcontroller-initramfs"
11IMAGE_NAME_SUFFIX ?= ""
12IMAGE_LINGUAS = ""
13
14LICENSE = "MIT"
15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
17inherit core-image
18
19IMAGE_ROOTFS_SIZE = "8192"
20IMAGE_ROOTFS_EXTRA_SPACE = "0"
21BAD_RECOMMENDATIONS += "busybox-syslog"
22
23# Use the same restriction as initramfs-live-install-testfs
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux"