blob: 8b715fac6bba04a3dc800dca95e352b20acbd7f8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Text file viewer similar to more"
2DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3based program for viewing text files and the output from other \
4programs. Less offers many features beyond those that more does."
5HOMEPAGE = "http://www.greenwoodsoftware.com/"
6SECTION = "console/utils"
7
8# (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
9# Including email author giving permissing to use BSD
10#
11# From: Mark Nudelman <markn@greenwoodsoftware.com>
12# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
13# Date: 12/19/11
14#
15# Hi Elizabeth,
16# Using a generic BSD license for less is fine with me.
17# Thanks,
18#
19# --Mark
20#
21
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022LICENSE = "GPL-3.0-or-later | BSD-2-Clause"
Andrew Geissler595f6302022-01-24 19:11:47 +000023LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
24 file://LICENSE;md5=38fc26d78ca8d284a2a5a4bbc263d29b \
25 "
26DEPENDS = "ncurses"
27
28SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz \
29 "
30
31SRC_URI[sha256sum] = "6633d6aa2b3cc717afb2c205778c7c42c4620f63b1d682f3d12c98af0be74d20"
32
33UPSTREAM_CHECK_URI = "http://www.greenwoodsoftware.com/less/download.html"
34
35inherit autotools update-alternatives
36
37do_install () {
38 oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
39}
40
41ALTERNATIVE:${PN} = "less"
42ALTERNATIVE_PRIORITY = "100"