blob: 8a13dcf9d0dadb636e334aa325822a5fbae222fb [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
22
23CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
24CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
25SRCREV = "b0561ad8d9ee9fe1244b5385e941eb65a21e91a1"
26
27SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
28 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
29 file://0001-metadata-parse.sh-sort-filelist-for-reproducibility.patch \
30 file://disable_hanging_tests.patch \
31 "
32
33S = "${WORKDIR}/git"
34
35inherit autotools-brokensep pkgconfig
36
37TARGET_CC_ARCH += "${LDFLAGS}"
38
39export prefix = "/opt/${PN}"
40export exec_prefix = "/opt/${PN}"
41
42PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
43EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
44EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
45# ltp network/rpc test cases ftbfs when libtirpc is found
46EXTRA_OECONF += " --without-tirpc "
47
48do_compile() {
49 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}"
50}
51
52do_install(){
53 install -d ${D}${prefix}/
54 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
55
56 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
57 # as it lacks dependency on some perl moudle such as LWP::Simple
58 # And this script previously works as a tool for analyzing failures from LTP
59 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
60 # http://khack.osdl.org to retrieve ltp test results run on
61 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
62 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
63
64 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
65 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
66
67 # Makefile were configured in the build system
68 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
69 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
70 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
71 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
72 -e 's@[^ ]*--sysroot=[^ "]*@@g'
73
74 # The controllers memcg_stree test seems to cause us hangs and takes 900s
75 # (maybe we expect more regular output?), anyhow, skip it
76 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
77}
78
79RDEPENDS:${PN} = "\
80 attr \
81 bash \
82 bc \
83 coreutils \
84 cpio \
85 cronie \
86 curl \
87 e2fsprogs \
88 e2fsprogs-mke2fs \
89 expect \
90 file \
91 gawk \
92 gdb \
93 gzip \
94 iproute2 \
95 ldd \
96 libaio \
97 logrotate \
98 net-tools \
99 perl \
100 python3-core \
101 procps \
102 quota \
103 unzip \
104 util-linux \
105 which \
106 tar \
107"
108
109FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
110
111# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
112INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
113INSANE_SKIP:${PN} += "already-stripped staticdev"
114
115remove_broken_musl_sources() {
116 [ "${TCLIBC}" = "musl" ] || return 0
117
118 cd ${S}
119 echo "WARNING: remove unsupported tests (until they're fixed)"
120
121 # sync with upstream
122 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
123 rm -rfv \
124 testcases/kernel/syscalls/confstr/confstr01.c \
125 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
126 testcases/kernel/syscalls/getcontext/getcontext01.c \
127 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
128 testcases/kernel/syscalls/timer_create/timer_create01.c \
129 testcases/kernel/syscalls/timer_create/timer_create03.c \
130 utils/benchmark/ebizzy-0.3
131}
132do_patch[postfuncs] += "remove_broken_musl_sources"
133
134# Avoid file dependency scans, as LTP checks for things that may or may not
135# exist on the running system. For instance it has specific checks for
136# csh and ksh which are not typically part of OpenEmbedded systems (but
137# can be added via additional layers.)
138SKIP_FILEDEPS:${PN} = '1'