blob: 2714582957cc57116cab79eaadacf918ecd809bd [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Convert::ASN1 - Perl ASN.1 Encode/Decode library"
2SECTION = "libs"
3HOMEPAGE = "http://search.cpan.org/dist/Convert-ASN1/"
4DESCRIPTION = "Convert::ASN1 is a perl library for encoding/decoding data using ASN.1 definitions."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geisslereff27472021-10-29 15:35:00 -05006LIC_FILES_CHKSUM = "file://README.md;beginline=91;endline=97;md5=ceff7fd286eb6d8e8e0d3d23e096a63f"
7
8SRC_URI = "https://cpan.metacpan.org/authors/id/T/TI/TIMLEGGE/Convert-ASN1-${PV}.tar.gz"
9
10SRC_URI[sha256sum] = "1fdf004520c79e3a244cf9688616293516c11793d746c761f367496eb3d06076"
11
12S = "${WORKDIR}/Convert-ASN1-${PV}"
13
14inherit cpan ptest-perl
15
16EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}"
17
18RDEPENDS:${PN} += "perl-module-exporter perl-module-constant perl-module-encode perl-module-encode-encoding perl-module-utf8 perl-module-socket perl-module-time-local perl-module-posix"
19RDEPENDS:${PN}-ptest += "perl-module-math-bigint perl-module-io-socket perl-module-data-dumper perl-module-math-bigint-calc"
20
21BBCLASSEXTEND = "native"