blob: 12e10951a6c61e6df5b795fb03b71ac9434b480a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master"
9SRCREV = "48be8ff4ffc4a04a0e3b5f2feaf63cce0cbd4f2b"
10S = "${WORKDIR}/git"
11
12DEPENDS = "coreutils-native"
13
14PROVIDES = "stress"
15RPROVIDES:${PN} = "stress"
16RREPLACES:${PN} = "stress"
17RCONFLICTS:${PN} = "stress"
18
19inherit bash-completion
20
21do_install() {
22 oe_runmake DESTDIR=${D} install
23 ln -s stress-ng ${D}${bindir}/stress
24}