blob: c8a50735b1aa9d31b12e53964d712c92acb1218d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Displays the full path of shell commands"
2DESCRIPTION = "Which is a utility that prints out the full path of the \
3executables that bash(1) would execute when the passed \
4program names would have been entered on the shell prompt. \
5It does this by using the exact same algorithm as bash."
6SECTION = "libs"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007HOMEPAGE = "https://carlowood.github.io/which/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "GPL-3.0-or-later"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
11 file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
12DEPENDS = "cwautomacros-native"
13
14inherit autotools texinfo update-alternatives
15
16PR = "r3"
17
18EXTRA_OECONF = "--disable-iberty"
19
20SRC_URI = "${GNU_MIRROR}/which/which-${PV}.tar.gz \
21 file://automake.patch \
22 "
23
24SRC_URI[md5sum] = "097ff1a324ae02e0a3b0369f07a7544a"
25SRC_URI[sha256sum] = "f4a245b94124b377d8b49646bf421f9155d36aa7614b6ebf83705d3ffc76eaad"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027do_configure:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028 sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
29}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031ALTERNATIVE:${PN} = "which"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032ALTERNATIVE_PRIORITY = "100"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033
Patrick Williams213cb262021-08-07 19:21:33 -050034ALTERNATIVE:${PN}-doc = "which.1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060036
37BBCLASSEXTEND = "nativesdk"