blob: 6dca6a7305712e61bf3200ed149daee1082f64a3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "WebKit based web browser for GNOME"
2DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \
3It provides a simple and easy-to-use internet browsing experience."
4HOMEPAGE = "https://wiki.gnome.org/Apps/Web"
5BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00007LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9DEPENDS = " \
10 webkitgtk \
11 gcr \
12 gsettings-desktop-schemas \
13 nettle \
14 json-glib \
15 libarchive \
16 libdazzle \
17 libhandy \
18 glib-2.0-native \
19 "
20
21GNOMEBASEBUILDCLASS = "meson"
22inherit gnomebase gsettings features_check gettext mime-xdg
23REQUIRED_DISTRO_FEATURES = "x11 opengl"
24
25SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
26 file://0002-help-meson.build-disable-the-use-of-yelp.patch \
27 file://bfbb5f7bab38301d8a4a444173acdae8d9692146.patch \
28 file://migrator.patch \
29 file://distributor.patch \
30 "
31SRC_URI[archive.sha256sum] = "ba01268ee54f318dfdac2e01eba38a3fc96940c1cbf640ed2613ae29f8bcb9ad"
32
33PACKAGECONFIG_SOUP ?= "soup2"
34PACKAGECONFIG ??= "${PACKAGECONFIG_SOUP}"
35
36# Developer mode enables debugging
37PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false"
38PACKAGECONFIG[soup2] = "-Dsoup2=enabled,-Dsoup2=disabled,libsoup-2.4,,,soup3"
39PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
40PACKAGECONFIG[libportal] = "-Dlibportal=enabled,-Dlibportal=disabled,libportal"
41
42FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
43RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"