blob: 627f3895360f276e4aec00b8c203d92a2ccdac15 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
8
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "LGPL-2.1-only"
Andrew Geisslereff27472021-10-29 15:35:00 -050010LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0"
13
14GNOMEBASEBUILDCLASS = "meson"
15inherit gnomebase lib_package gobject-introspection gi-docgen gettext ptest-gnome manpages upstream-version-is-even
16GIR_MESON_ENABLE_FLAG = 'enabled'
17GIR_MESON_DISABLE_FLAG = 'disabled'
18GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'
19GIDOCGEN_MESON_DISABLE_FLAG = 'disabled'
20
21SRC_URI += " file://run-ptest"
22SRC_URI[archive.sha256sum] = "96ec98be7a91f6dde33636720e3da2ff6ecbb90e76ccaa49497f31a6855a490e"
23
24PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
25PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
26PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
27
28BBCLASSEXTEND = "native nativesdk"
29
30# Currently it's not possible to disable gettext in Meson, so we need to force
31# this back on.
32USE_NLS:class-native = "yes"