blob: 6dbfd322178e49dbc4402f9e585d46e1cdd7b6c7 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014LICENSE = "MIT & MIT & PD"
Brad Bishopc342db32019-05-15 21:57:59 -040015LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1671;endline=1686;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib gperf-native util-linux"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 "
26
27SRC_URI[md5sum] = "690c6cb840a92fa8908cdf462d19ec66"
28SRC_URI[sha256sum] = "9f0d852b39d75fc655f9f53850eb32555394f36104a044bb2b2fc9e66dbbfa7f"
29
30UPSTREAM_CHECK_REGEX = "fontconfig-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040033 # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280
34 rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf
35}
36
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:append:class-target() {
Brad Bishopc342db32019-05-15 21:57:59 -040038 # duplicate fc-cache for postinstall script
39 mkdir -p ${D}${libexecdir}
40 ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache
41}
42
Patrick Williams213cb262021-08-07 19:21:33 -050043do_install:append:class-nativesdk() {
Brad Bishopc342db32019-05-15 21:57:59 -040044 # duplicate fc-cache for postinstall script
45 mkdir -p ${D}${libexecdir}
46 ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache
47}
48
49PACKAGES =+ "fontconfig-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050050FILES:${PN} =+ "${datadir}/xml/*"
51FILES:${PN}-dev += "${datadir}/gettext/*"
52FILES:fontconfig-utils = "${bindir}/* ${libexecdir}/*"
Brad Bishopc342db32019-05-15 21:57:59 -040053
54# Work around past breakage in debian.bbclass
Patrick Williams213cb262021-08-07 19:21:33 -050055RPROVIDES:fontconfig-utils = "libfontconfig-utils"
56RREPLACES:fontconfig-utils = "libfontconfig-utils"
57RCONFLICTS:fontconfig-utils = "libfontconfig-utils"
58DEBIAN_NOAUTONAME:fontconfig-utils = "1"
Brad Bishopc342db32019-05-15 21:57:59 -040059
60inherit autotools pkgconfig relative_symlinks gettext
61
62FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
63
64# comma separated list of additional directories
65# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
66FONTCONFIG_FONT_DIRS ?= "no"
67
68EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
69
70BBCLASSEXTEND = "native nativesdk"