blob: 5055ff185c39ffbe14c881672d26943d73032002 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "FTL | GPL-2.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +000011LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=a5927784d823d443c6cae55701d01553 \
12 file://docs/FTL.TXT;md5=9f37b4e6afa3fef9dba8932b16bd3f97 \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
15SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BP}.tar.xz"
16SRC_URI[sha256sum] = "3333ae7cfda88429c97a7ae63b7d01ab398076c3b67182e960e5684050f2c5c8"
17
18UPSTREAM_CHECK_REGEX = "freetype-(?P<pver>\d+(\.\d+)+)"
19
20inherit autotools pkgconfig multilib_header
21
22# Adapt autotools to work with the minimal autoconf usage in freetype
23AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
24CONFIGURE_SCRIPT = "${S}/configure"
25EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
26
27PACKAGECONFIG ??= "zlib pixmap"
28
29PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
30# harfbuzz results in a circular dependency so enabling is non-trivial
31PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
32PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
33PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
34PACKAGECONFIG[freetypeconfig] = "--enable-freetype-config=yes,--enable-freetype-config=no,"
35
36EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
37
38TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
39
40do_install:append() {
41 oe_multilib_header freetype2/freetype/config/ftconfig.h
42}
43
44BBCLASSEXTEND = "native nativesdk"