blob: e392aa3b3339e53eac04f2758a2ddc1edf364b84 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \
9 "
10
11UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
12UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
13
14SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz"
15SRC_URI[sha256sum] = "7158a87c4db82521fc506711f0c8864115f0292d95f7136c8812c11811cdf952"
16
17inherit meson pkgconfig lib_package gtk-doc gobject-introspection
18
19GIR_MESON_ENABLE_FLAG = 'enabled'
20GIR_MESON_DISABLE_FLAG = 'disabled'
21GTKDOC_MESON_ENABLE_FLAG = 'enabled'
22GTKDOC_MESON_DISABLE_FLAG = 'disabled'
23
24PACKAGECONFIG ??= "cairo freetype glib icu"
25PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
26PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype"
27PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0"
28PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2"
29PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu"
30
31PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
32
33LEAD_SONAME = "libharfbuzz.so"
34
35do_install:append() {
36 # If no tools are installed due to PACKAGECONFIG then this directory is
37 #still installed, so remove it to stop packaging wanings.
38 rmdir --ignore-fail-on-non-empty ${D}${bindir}
39}
40
41FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
42FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
43 ${libdir}/libharfbuzz-icu.so \
44 ${libdir}/pkgconfig/harfbuzz-icu.pc \
45"
46FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
47
48BBCLASSEXTEND = "native nativesdk"