blob: 81704beac46570b87b76fbc736d3728f6d2f9732 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Matchbox lightweight window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
7 file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
8 file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes"
12
13# SRCREV tagged 1.2.2
14SRCREV = "27da947e7fbdf9659f7e5bd1e92af92af6c03970"
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager;branch=master \
Andrew Geisslerc182c622020-05-15 14:13:32 -050016 file://0001-Fix-build-with-gcc-10.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017 file://kbdconfig"
18
19S = "${WORKDIR}/git"
20
Brad Bishop6dbb3162019-11-25 09:41:34 -050021inherit autotools pkgconfig features_check
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022# depends on virtual/libx11
23REQUIRED_DISTRO_FEATURES = "x11"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} = "${bindir}/* \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 ${datadir}/matchbox \
27 ${sysconfdir}/matchbox \
28 ${datadir}/themes/blondie/matchbox \
29 ${datadir}/themes/Default/matchbox \
30 ${datadir}/themes/MBOpus/matchbox"
31
32EXTRA_OECONF = " --enable-startup-notification \
33 --disable-xrm \
34 --enable-expat \
35 --with-expat-lib=${STAGING_LIBDIR} \
36 --with-expat-includes=${STAGING_INCDIR}"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038do_install:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
40}