blob: 0ff82036e7e9f5b82be64100ec1c06b938bc8900 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A C library for selecting an OpenGL API and window system at runtime"
2DESCRIPTION = "A cross-platform C library that allows one to defer selection \
3of an OpenGL API and window system until runtime. For example, on Linux, Waffle \
4enables an application to select X11/EGL with an OpenGL 3.3 core profile, \
5Wayland with OpenGL ES2, and other window system / API combinations."
6HOMEPAGE = "https://gitlab.freedesktop.org/mesa/waffle"
7BUGTRACKER = "https://gitlab.freedesktop.org/mesa/waffle"
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
10 file://include/waffle-1/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
11
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://gitlab.freedesktop.org/mesa/waffle.git;protocol=https;branch=master \
Andrew Geisslereff27472021-10-29 15:35:00 -050013 file://0001-waffle-do-not-make-core-protocol-into-the-library.patch \
14 "
15SRCREV = "905c6c10f2483adf0cbfa024e2d3c2ed541fb300"
16S = "${WORKDIR}/git"
17
18inherit meson features_check lib_package bash-completion pkgconfig
19
Andrew Geissler595f6302022-01-24 19:11:47 +000020DEPENDS:append = " python3 cmake-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050021
22# This should be overridden per-machine to reflect the capabilities of the GL
23# stack.
24PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
26 surfaceless-egl gbm"
27
28# virtual/libgl requires opengl in DISTRO_FEATURES.
29REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}"
30
31# I say virtual/libgl, actually wants gl.pc
32PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/${MLPREFIX}libgl libx11"
33
34# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
35# DISTRO_FEATURE.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000036PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,virtual/${MLPREFIX}libgl wayland wayland-native wayland-protocols"
Andrew Geisslereff27472021-10-29 15:35:00 -050037
38# I say virtual/libgl, actually wants gbm.pc egl.pc
39PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/${MLPREFIX}libgl udev"
40
41# I say virtual/libgl, actually wants egl.pc
42PACKAGECONFIG[x11-egl] = "-Dx11_egl=enabled,-Dx11_egl=disabled,virtual/${MLPREFIX}libgl libxcb"
43PACKAGECONFIG[surfaceless-egl] = "-Dsurfaceless_egl=enabled,-Dsurfaceless_egl=disabled,virtual/${MLPREFIX}libgl"
44
45# TODO: optionally build manpages and examples
46
47do_install:append() {
48 sed -i -e "s,${WORKDIR},,g" ${D}/${libdir}/cmake/Waffle/WaffleConfig.cmake
49}