blob: 90917ef4374b257095fc01bcc38b32d0cc7072b0 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "SM: Session Management library"
2
3DESCRIPTION = "The Session Management Library (SMlib) is a low-level \"C\" \
4language interface to XSMP. The purpose of the X Session Management \
5Protocol (XSMP) is to provide a uniform mechanism for users to save and \
6restore their sessions. A session is a group of clients, each of which \
7has a particular state."
8
9require xorg-lib-common.inc
10
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011LICENSE = "MIT"
Brad Bishop19323692019-04-05 15:28:33 -040012LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d"
13
14DEPENDS += "libice xorgproto xtrans"
15
16# libSM can work without libuuid, we explicitly disable it to break the following circular dependency
17# when DISTRO_FEATURES contains 'systemd' and 'x11'.
18# systemd -> dbus -> libsm -> util-linux -> systemd
19EXTRA_OECONF += "--without-libuuid"
20
21PE = "1"
22
23XORG_PN = "libSM"
24
25SRC_URI[md5sum] = "87c7fad1c1813517979184c8ccd76628"
26SRC_URI[sha256sum] = "2d264499dcb05f56438dee12a1b4b71d76736ce7ba7aa6efbf15ebb113769cbb"
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
30
31BBCLASSEXTEND = "native nativesdk"