blob: 34652e9c4ec48a42f94961f31ff0c5db6e7fb194 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Generic XKB keymap library"
2DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \
3processes a reduced subset of keymaps as defined by the XKB specification."
4HOMEPAGE = "http://www.xkbcommon.org"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87"
6LICENSE = "MIT & MIT"
7
8DEPENDS = "flex-native bison-native"
9
10SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz"
11
12SRC_URI[sha256sum] = "106cec5263f9100a7e79b5f7220f889bc78e7d7ffc55d2b6fdb1efefb8024031"
13
14UPSTREAM_CHECK_URI = "http://xkbcommon.org/"
15
16inherit meson pkgconfig
17
18PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} xkbregistry"
19
20PACKAGECONFIG[docs] = "-Denable-docs=true,-Denable-docs=false,doxygen-native"
21PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols,"
22PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config,"
23PACKAGECONFIG[xkbregistry] = "-Denable-xkbregistry=true,-Denable-xkbregistry=false,libxml2"
24
25PACKAGE_BEFORE_PN += "xkbcli"
26FILES:${PN} = ""
27FILES:xkbcli = "${bindir}/xkbcli ${libexecdir}/xkbcommon/xkbcli-*"
28
29python populate_packages:prepend () {
30 # Put the libraries into separate packages to avoid dependency creep
31 do_split_packages(d, d.expand('${libdir}'), r'^(lib.*)\.so\.*', '%s', '%s library', extra_depends='', allow_links=True)
32}
33
34# Fix a following runtime error:
35# xkbcommon: ERROR: couldn't find a Compose file for locale "C"
36RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}"