blob: f82a6960e6c6054adeab5f36e1cd09564c096169 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "X.Org X server configuration file"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LICENSE = "MIT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6PR = "r33"
7
8SRC_URI = "file://xorg.conf"
9
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010S = "${WORKDIR}"
11
Patrick Williams213cb262021-08-07 19:21:33 -050012CONFFILES:${PN} = "${sysconfdir}/X11/xorg.conf"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
14PACKAGE_ARCH = "${MACHINE_ARCH}"
Patrick Williams213cb262021-08-07 19:21:33 -050015ALLOW_EMPTY:${PN} = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
17do_install () {
18 if test -s ${WORKDIR}/xorg.conf; then
19 install -d ${D}/${sysconfdir}/X11
20 install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
21 fi
22}