blob: 801a6f0584dd73d44d7188979a95cd67ac0ef786 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Wireless Central Regulatory Domain Database"
2HOMEPAGE = "https://wireless.wiki.kernel.org/en/developers/regulatory/crda"
3SECTION = "net"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
6
7SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
8SRC_URI[sha256sum] = "8828c25a4ee25020044004f57374bb9deac852809fad70f8d3d01770bf9ac97f"
9
10inherit bin_package allarch
11
12do_install() {
13 install -d -m0755 ${D}${nonarch_libdir}/crda
14 install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
15 install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
16 install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
17
18 install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
19 install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
20}
21
22# Install static regulatory DB in /lib/firmware for kernel to load.
23# This requires Linux kernel >= v4.15.
24# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass
25# (in meta-networking) in kernel's recipe.
26PACKAGES = "${PN}-static ${PN}"
27RCONFLICTS:${PN} = "${PN}-static"
28
29FILES:${PN}-static = " \
30 ${nonarch_base_libdir}/firmware/regulatory.db \
31 ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
32"
33
34# Native users might want to use the source of regulatory DB.
35# This is for example used by Linux kernel <= v4.14 and
36# kernel_wireless_regdb.bbclass in meta-networking.
37do_install:append:class-native() {
38 install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
39}
40
41RSUGGESTS:${PN} = "crda"
42
43BBCLASSEXTEND = "native"