blob: 8430dee10373681233f55e1c81fab9d0a59cd98e [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Audio format Conversion library"
2DESCRIPTION = "Library for reading and writing files containing sampled \
3sound (such as MS Windows WAV and the Apple/SGI AIFF format) through \
4one standard library interface."
5HOMEPAGE = "https://libsndfile.github.io/libsndfile/"
6AUTHOR = "Erik de Castro Lopo"
7DEPENDS = "flac libogg libvorbis"
8SECTION = "libs/multimedia"
9LICENSE = "LGPL-2.1-only"
10
11SRC_URI = "https://github.com/libsndfile/libsndfile/releases/download/${PV}/libsndfile-${PV}.tar.bz2 \
12 "
13
14SRC_URI[md5sum] = "3f3b2a86a032f064ef922a2c8c191f7b"
15SRC_URI[sha256sum] = "a8cfb1c09ea6e90eff4ca87322d4168cdbe5035cb48717b40bf77e751cc02163"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a"
18
19CVE_PRODUCT = "libsndfile"
20
21S = "${WORKDIR}/libsndfile-${PV}"
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
24PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
25PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3"
26
27inherit autotools lib_package pkgconfig multilib_header
28
29do_install:append() {
30 oe_multilib_header sndfile.h
31}