blob: 2dcc80965a39d416dc93579baf1e22066a87677b [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
4SECTION = "tests"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-only"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9inherit python3-dir
10
11EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
12
13do_compile() {
14 oe_runmake hwlatdetect
15}
16
17do_install() {
18 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
19 MANDIR=${mandir} INCLUDEDIR=${includedir}
20
21 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py
22}
23
Patrick Williams213cb262021-08-07 19:21:33 -050024FILES:${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
25RDEPENDS:${PN} = "python3-core "
26RRECOMMENDS:${PN} = "kernel-module-hwlat-detector"