blob: b05a9c48ad4d42a8083ffe8a84e3fe8ec217b917 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Matchbox Window Manager Desktop"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A lightweight windows manager for embedded systems. It uses the desktop background to provide an application launcher and allows modules to be loaded for additional functionality."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05003HOMEPAGE = "http://matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.org/"
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \
9 file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00"
10
11DEPENDS = "gtk+3 startup-notification dbus"
12SECTION = "x11/wm"
13
14# SRCREV tagged 2.2
15SRCREV = "6bc67d09da4147e5552fe30011a05a2c59d2f777"
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://git.yoctoproject.org/${BPN}-2;branch=master \
Andrew Geisslerc9f78652020-09-18 14:11:35 -050017 file://vfolders/ \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018 "
19
20EXTRA_OECONF = "--enable-startup-notification --with-dbus"
21
22S = "${WORKDIR}/git"
23
Brad Bishop6dbb3162019-11-25 09:41:34 -050024inherit autotools pkgconfig features_check
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025
26# The startup-notification requires x11 in DISTRO_FEATURES
27REQUIRED_DISTRO_FEATURES = "x11"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030 install -d ${D}${datadir}/matchbox/vfolders/
31 install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/
32}
33
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} += "${datadir}/matchbox/vfolders/"