blob: 020e211ea595ab5c98f90f819d3f9c171bea0575 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Custom Matchbox session files for the Sato environment"
2HOMEPAGE = "http://www.matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-or-later"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
7
8SECTION = "x11"
Patrick Williams213cb262021-08-07 19:21:33 -05009RDEPENDS:${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop matchbox-session gconf"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010PR = "r30"
11
12# This package is architecture specific because the session script is modified
13# based on the machine architecture.
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
Brad Bishop6dbb3162019-11-25 09:41:34 -050016inherit features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017
18# The matchbox-theme-sato requires x11 in DISTRO_FEATURES
19REQUIRED_DISTRO_FEATURES = "x11"
20
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021SRC_URI = "file://session \
22 file://index.theme"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023S = "${WORKDIR}"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} += "${datadir}/themes/Sato/index.theme"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060026
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027do_install() {
28 # This is the set of machine features that the script has markers for
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029 FEATURES="acpi apm phone"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030 SCRIPT="${S}/sedder"
31 rm -f $SCRIPT
32 touch $SCRIPT
33 for FEAT in $FEATURES; do
34 if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
35 echo "/feature-$FEAT/d" >> $SCRIPT
36 fi
37 done
38
Patrick Williamsc0f7c042017-02-23 20:41:17 -060039 install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040 install -d ${D}/${sysconfdir}/matchbox
41 sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
42 chmod +x ${D}/${sysconfdir}/matchbox/session
43}
44
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045PACKAGE_WRITE_DEPS += "gconf-native"
Patrick Williams213cb262021-08-07 19:21:33 -050046pkg_postinst:${PN} () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047 set_value() {
48 #type, name, value
49 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
50 }
Patrick Williamsc0f7c042017-02-23 20:41:17 -060051 set_value string theme Adwaita
52 set_value string matchbox_theme Sato
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053 set_value string icon_theme Sato
54 set_value bool touchscreen true
55 set_value string font_name "Sans 9"
56}