blob: 588894cb9a8301fe9ea9dcdf6934b5a1b6bc60df [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "in-depth comparison of files, archives, and directories"
2DESCRIPTION = "Tries to get to the bottom of what makes files or directories \
3different. It will recursively unpack archives of many kinds and transform \
4various binary formats into more human-readable form to compare them. \
5It can compare two tarballs, ISO images, or PDF just as easily."
6HOMEPAGE = "https://diffoscope.org/"
7BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues"
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11PYPI_PACKAGE = "diffoscope"
12
13inherit pypi setuptools3
14
15SRC_URI[sha256sum] = "cc99eb4cd9555947b11d6abb7ba83e71234f92ad1372e3b61e934115192ecb4e"
16
17RDEPENDS:${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm"
18
19# Dependencies don't build for musl
20COMPATIBLE_HOST:libc-musl = 'null'
21
22do_install:append:class-native() {
23 create_wrapper ${D}${bindir}/diffoscope \
24 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
25 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
26 LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
27 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
28}
29
30BBCLASSEXTEND = "native"