blob: 81361d902ce40e596ae988bd53f457598a397d46 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2DESCRIPTION = "A complete and free implementation of the OpenPGP standard \
3as defined by RFC4880 (also known as PGP). GnuPG allows you to encrypt \
4and sign your data and communications; it features a versatile key \
5management system, along with access modules for all kinds of public \
6key directories."
7HOMEPAGE = "http://www.gnupg.org/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-3.0-only & LGPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00009LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
10 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
11
12DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
13
14inherit autotools gettext texinfo pkgconfig
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
18 file://0002-use-pkgconfig-instead-of-npth-config.patch \
19 file://0003-dirmngr-uses-libgpg-error.patch \
20 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
21 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
22 "
23SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
24 file://relocate.patch"
25SRC_URI:append:class-nativesdk = " file://relocate.patch"
26
27SRC_URI[sha256sum] = "f3468ecafb1d7f9ad7b51fd1db7aebf17ceb89d2efa8a05cf2f39b4d405402ae"
28
29EXTRA_OECONF = "--disable-ldap \
30 --disable-ccid-driver \
31 --with-zlib=${STAGING_LIBDIR}/.. \
32 --with-bzip2=${STAGING_LIBDIR}/.. \
33 --with-readline=${STAGING_LIBDIR}/.. \
34 --with-mailprog=${sbindir}/sendmail \
35 --enable-gpg-is-gpg2 \
36 "
37
38# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
39PACKAGES =+ "${PN}-gpg"
40FILES:${PN}-gpg = " \
41 ${bindir}/gpg \
42 ${bindir}/gpg2 \
43 ${bindir}/gpg-agent \
44"
45
46# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
47# to ensure all tools are included. This is done only in non-native
48# builds. Native builds don't have sub-packages, so appending RDEPENDS
49# in this case breaks recipe parsing.
50RDEPENDS:${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
51
52RRECOMMENDS:${PN} = "pinentry"
53
54do_configure:prepend () {
55 # Else these could be used in prefernce to those in aclocal-copy
56 rm -f ${S}/m4/gpg-error.m4
57 rm -f ${S}/m4/libassuan.m4
58 rm -f ${S}/m4/ksba.m4
59 rm -f ${S}/m4/libgcrypt.m4
60}
61
62do_install:append() {
63 ln -sf gpg2 ${D}${bindir}/gpg
64 ln -sf gpgv2 ${D}${bindir}/gpgv
65}
66
67do_install:append:class-native() {
68 create_wrappers ${STAGING_BINDIR_NATIVE}
69}
70
71do_install:append:class-nativesdk() {
72 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
73}
74
75create_wrappers() {
76 for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
77 create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
78 done
79}
80
81PACKAGECONFIG ??= "gnutls"
82PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
83PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
84
85BBCLASSEXTEND = "native nativesdk"