blob: bb8766a0708b6294204b0d60cf5354edd3d5cb82 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "https://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
13# License: BSD-2-clause
14# License: BSD-2-clause-NetBSD
15# License: BSD-2-clause-author
16# License: BSD-2-clause-verbatim
17# License: BSD-3-clause
18# License: BSD-3-clause-author
19# License: BSD-3-clause-John-Birrell
20# License: BSD-3-clause-Regents
21# License: BSD-4-clause-Christopher-G-Demetriou
22# License: BSD-4-clause-Niels-Provos
23# License: BSD-5-clause-Peter-Wemm
24# License: Beerware
25# License: Expat
26# License: ISC
27# License: ISC-Original
28# License: public-domain
29# License: public-domain-Colin-Plumb
30LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
31LICENSE:${PN} = "BSD-3-Clause & ISC & PD"
32LIC_FILES_CHKSUM = "file://COPYING;md5=0b31944ca2c1075410a30f0c17379d3b"
33SECTION = "libs"
34
35SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
36
37SRC_URI[sha256sum] = "1a9c952525635c1bb6770cb22e969b938d8e6a9d7912362b98ee8370599b0efd"
38
39inherit autotools pkgconfig
40
41DEPENDS += "libmd"
42
43BBCLASSEXTEND = "native nativesdk"