blob: 188d689cc3b9fed3c04e363ae1c25ddd276d5b42 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Check - unit testing framework for C code"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "It features a simple interface for defining unit tests, \
3putting little in the way of the developer. Tests are run in a separate \
4address space, so both assertion failures and code errors that cause \
5segmentation faults or other signals can be caught. Test results are \
6reportable in the following: Subunit, TAP, XML, and a generic logging format."
Andrew Geissler82c905d2020-04-13 13:39:40 -05007HOMEPAGE = "https://libcheck.github.io/check/"
8SECTION = "devel"
9
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "LGPL-2.1-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
12
13SRC_URI = "https://github.com/${BPN}/check/releases/download/${PV}/check-${PV}.tar.gz \
14 file://not-echo-compiler-info-to-check_stdint.h.patch"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050015SRC_URI[sha256sum] = "a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016UPSTREAM_CHECK_URI = "https://github.com/libcheck/check/releases/"
17
18S = "${WORKDIR}/check-${PV}"
19
20inherit autotools pkgconfig texinfo
21
22CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RREPLACES:${PN} = "check (<= 0.9.5)"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26BBCLASSEXTEND = "native nativesdk"
27
28PACKAGES =+ "checkmk"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030FILES:checkmk = "${bindir}/checkmk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:checkmk = "gawk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050033