blob: 20ba0ef2829d2dd7d59ecab60b796c2ae2c06029 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2DESCRIPTION = "libexif is a library for parsing, editing, and saving EXIF data. It is \
3intended to replace lots of redundant implementations in command-line \
4utilities and programs with GUIs."
5HOMEPAGE = "https://libexif.github.io/"
6SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
9
10def version_underscore(v):
11 return "_".join(v.split("."))
12
13SRC_URI = "https://github.com/libexif/libexif/releases/download/v${PV}/libexif-${PV}.tar.bz2 \
14 "
15
16SRC_URI[sha256sum] = "d47564c433b733d83b6704c70477e0a4067811d184ec565258ac563d8223f6ae"
17
18UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/"
19
20inherit autotools gettext
21
22EXTRA_OECONF += "--disable-docs"
23
24BBCLASSEXTEND = "native nativesdk"