blob: da33893b97df63c2696f05eaa9b653a5417582cb [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception & MIT & OpenSSL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=e5a9227de4cb6afb5d35ed7b0fdf480d"
5
6DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.4;protocol=https"
9SRCREV = "fdd15bcfca6b2ec4b7ecad1aa11a396cb15bd064"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16 -DBUILD_CLAR=OFF \
17 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
18 -DLIB_INSTALL_DIR=${libdir} \
19 -DREGEX_BACKEND='pcre2' \
20"
21
22BBCLASSEXTEND = "native"