blob: e6260a77545ddcb5b64cd0ecff7e17a14a17f4a3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3HOMEPAGE = "https://github.com/seccomp/libseccomp"
4SECTION = "security"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
7
8DEPENDS += "gperf-native"
9
10SRCREV = "57357d2741a3b3d3e8425889a6b79a130e0fa2f3"
11
12SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5;protocol=https \
13 file://run-ptest \
14 "
15
16S = "${WORKDIR}/git"
17
18inherit autotools-brokensep pkgconfig ptest features_check
19
20REQUIRED_DISTRO_FEATURES = "seccomp"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
24
25DISABLE_STATIC = ""
26
27do_compile_ptest() {
28 oe_runmake -C tests check-build
29}
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 install -d ${D}${PTEST_PATH}/tools
34 for file in $(find tests/* -executable -type f); do
35 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
36 done
37 for file in $(find tests/*.tests -type f); do
38 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
39 done
40 for file in $(find tools/* -executable -type f); do
41 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
42 done
43 # Overwrite libtool wrappers with real executables
44 for file in $(find tools/.libs/* -executable -type f); do
45 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
46 done
47}
48
49FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
50FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
51
52RDEPENDS:${PN}-ptest = "coreutils bash"
53
54PV = "2.5.3"