blob: 775ab29ddd27d350ba3248c3894ffcb8a10fe3ca [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "An HTTP library implementation in C"
2DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
4HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
10DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl nghttp2"
11
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
15SRC_URI[sha256sum] = "5bd38b5e091f707fd7fa3ed7c37aacca3f8e16c65787f1cc17dc38d1dcde567b"
16
17PROVIDES = "libsoup-3.0"
18CVE_PRODUCT = "libsoup"
19
20S = "${WORKDIR}/libsoup-${PV}"
21
22inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
23
24GIR_MESON_ENABLE_FLAG = 'enabled'
25GIR_MESON_DISABLE_FLAG = 'disabled'
26
27# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
30
31EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
32
33GTKDOC_MESON_OPTION = "gtk_doc"
34
35# When built without gnome support, libsoup will contain only one shared lib
36# and will therefore become subject to renaming by debian.bbclass. Prevent
37# renaming in order to keep the package name consistent regardless of whether
38# gnome support is enabled or disabled.
39DEBIAN_NOAUTONAME:${PN} = "1"
40
41# glib-networking is needed for SSL, proxies, etc.
42RRECOMMENDS:${PN} = "glib-networking"
43
44BBCLASSEXTEND = "native nativesdk"