blob: 64cc19e47d8da00b36e37e4cd837c19fde28ea9b [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Userspace library to access USB (version 1.0)"
2DESCRIPTION = "A cross-platform library to access USB devices from Linux, \
3macOS, Windows, OpenBSD/NetBSD, Haiku and Solaris userspace."
4HOMEPAGE = "https://libusb.info"
5BUGTRACKER = "http://www.libusb.org/report"
6SECTION = "libs"
7
8LICENSE = "LGPL-2.1-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
10
11BBCLASSEXTEND = "native nativesdk"
12
13SRC_URI = "https://github.com/libusb/libusb/releases/download/v${PV}/libusb-${PV}.tar.bz2 \
14 file://run-ptest \
15 "
16
17UPSTREAM_CHECK_URI = "https://github.com/libusb/libusb/releases"
18
19SRC_URI[sha256sum] = "8a28ef197a797ebac2702f095e81975e2b02b2eeff2774fa909c78a74ef50849"
20
21S = "${WORKDIR}/libusb-${PV}"
22
23inherit autotools pkgconfig ptest
24
25PACKAGECONFIG:class-target ??= "udev"
26PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
27
28EXTRA_OECONF = "--libdir=${base_libdir}"
29
30do_install:append() {
31 install -d ${D}${libdir}
32 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
33 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
34 fi
35}
36
37do_compile_ptest() {
38 oe_runmake -C tests stress
39}
40
41do_install_ptest() {
42 install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH}
43}
44
45FILES:${PN} += "${base_libdir}/*.so.*"
46
47FILES:${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"