blob: 169cac896567415096f5a7c034d5271f609a6437 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11DEPENDS = "gettext-native libassuan libgpg-error"
12
13UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
14SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://libassuan_pkgconf.patch \
16 file://gpg-error_pkconf.patch \
17"
18
19SRC_URI[sha256sum] = "10072045a3e043d0581f91cd5676fcac7ffee957a16636adedaa4f583a616470"
20
21inherit autotools pkgconfig
22
23PACKAGECONFIG ??= "ncurses libcap"
24
25PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
26PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
27PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase"
28PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
29
30PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
31
32EXTRA_OECONF = " \
33 --disable-rpath \
34"
35
36BBCLASSEXTEND = "native nativesdk"