blob: b3b97025987b85d96cdfc03fde53ec339a18d103 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Extremely fast non-cryptographic hash algorithm"
2DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
3working at speeds close to RAM limits."
4HOMEPAGE = "http://www.xxhash.com/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "BSD-2-Clause & GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://LICENSE;md5=cdfe7764d5685d8e08b3df302885d7f3 \
7 file://cli/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 "
9
10SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=https"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13SRCREV = "35b0373c697b5f160d3db26b1cbb45a0d5ba788c"
14
15S = "${WORKDIR}/git"
16
17do_compile () {
18 oe_runmake all
19}
20
21do_install () {
22 oe_runmake DESTDIR=${D} install
23}
24
25BBCLASSEXTEND = "native nativesdk"