blob: 9d359d6244e34adf4684899248295bdaa11e2ca2 [file] [log] [blame]
Andrew Geissler72956ed2021-01-08 16:11:14 -06001SUMMARY = "yaml-cpp parser and emitter library"
2DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec."
3HOMEPAGE = "https://github.com/jbeder/yaml-cpp"
4SECTION = "devel"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
7
8# yaml-cpp releases are stored as archive files in github.
9# download the exact revision of release
10SRC_URI = "git://github.com/jbeder/yaml-cpp.git"
11SRCREV = "9a3624205e8774953ef18f57067b3426c1c5ada6"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE = "-DYAML_CPP_BUILD_TESTS=OFF -DYAML_BUILD_SHARED_LIBS=ON -DYAML_CPP_BUILD_TOOLS=OFF"