blob: 7c0663ab65dcd4227aaca01ee7778829a84e5e8b [file] [log] [blame]
Vijay Khemka7ec20042019-04-03 11:56:52 -07001SUMMARY = "Facebook OEM IPMI commands"
2DESCRIPTION = "Facebook OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
6
7SRC_URI = "git://github.com/openbmc/fb-ipmi-oem"
8SRCREV = "1b6fae3f3a3d0cd4e1c813a492e19d7edb55b4e9"
9
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd "
14
15inherit cmake obmc-phosphor-ipmiprovider-symlink
16
17EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
18
19LIBRARY_NAMES = "libzfboemcmds.so"
20
21HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
23
24FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
25FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
26FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
27FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
28
29do_install_append(){
30 install -d ${D}${includedir}/fb-ipmi-oem
31 install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/fb-ipmi-oem
32}