blob: 2795a8d091f6b0cdff71e1fff6c1dc76ef6dbc9e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2
3DESCRIPTION = "It provides tools to manage multipath devices \
4by instructing the device-mapper kernel module what to do. These \
5tools include: \
61. multipath - Scan the system for multipath devices and assemble them.\
72. multipathd - Detects when paths fail and execs multipath to update \
8things.\
93. mpathpersist - Persistent reservation management feature allows \
10cluster management software to manage persistent reservation through \
11mpath device. It processes management requests from callers and hides \
12the management task details. It also handles persistent reservation \
13management of data path life cycle and state changes.\
144. kpartx - This tool, derived from util-linux's partx, reads partition \
15tables on specified device and create device maps over partitions \
16segments detected. It is called from hotplug upon device maps creation \
17and deletion"
18
19HOMEPAGE = "http://christophe.varoqui.free.fr/"
20
21DEPENDS = "libdevmapper \
Brad Bishop0f291cc2019-09-01 15:16:57 -040022 lvm2 \
Brad Bishop19323692019-04-05 15:28:33 -040023 libaio \
24 liburcu \
25 readline \
26 udev \
27 json-c \
28 "
29
30LICENSE = "GPLv2"
31
32SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
33 file://multipathd.oe \
34 file://multipath.conf.example \
35 file://0021-RH-fixup-udev-rules-for-redhat.patch \
36 file://0022-RH-Remove-the-property-blacklist-exception-builtin.patch \
37 file://0023-RH-don-t-start-without-a-config-file.patch \
38 file://0024-RH-use-rpm-optflags-if-present.patch \
39 file://0025-RH-add-mpathconf.patch \
40 file://0026-RH-add-wwids-from-kernel-cmdline-mpath.wwids-with-A.patch \
41 file://0027-RH-warn-on-invalid-regex-instead-of-failing.patch \
42 file://0028-RH-reset-default-find_mutipaths-value-to-off.patch \
43 file://0029-multipath-tools-modify-Makefile.inc-for-cross-compil.patch \
44 file://0030-Always-use-devmapper.patch \
45 file://0031-Always-use-devmapper-for-kpartx.patch \
Andrew Geissler7f40b712020-05-15 14:09:53 -050046 file://0001-fix-bug-of-do_compile-and-do_install.patch \
Brad Bishop19323692019-04-05 15:28:33 -040047 "
48
49LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
50
Andrew Geissler7f40b712020-05-15 14:09:53 -050051SRCREV = "d4915917655b3d205aa0e339ca13080ed8182d0d"
Brad Bishop19323692019-04-05 15:28:33 -040052
53S = "${WORKDIR}/git"
54
55inherit systemd pkgconfig
56
57SYSTEMD_SERVICE_${PN} = "multipathd.service"
58SYSTEMD_AUTO_ENABLE = "disable"
59
60TARGET_CC_ARCH += "${LDFLAGS}"
61
62# multipath-tools includes a copy of the valgrind.h header
63# file and uses the macros to suppress some false positives. However,
64# that only works on ARM when thumb is disabled. Otherwise one gets:
65# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
66# ../Makefile.inc:66: recipe for target 'debug.o' failed
67ARM_INSTRUCTION_SET_armv4 = "arm"
68ARM_INSTRUCTION_SET_armv5 = "arm"
69
70# The exact version of SYSTEMD does not matter but should be greater than 209.
71#
72EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
73 OPTFLAGS="${CFLAGS}" \
74 bindir=${base_sbindir} \
75 LIB=${base_libdir} libdir=${base_libdir}/multipath \
76 unitdir=${systemd_system_unitdir} \
Brad Bishop0e2770c2020-01-21 07:31:46 -050077 libudevdir=${nonarch_base_libdir}/udev \
Brad Bishop19323692019-04-05 15:28:33 -040078 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
79 '
80
81do_install() {
82 oe_runmake install
83
84 # We copy an initscript, but do not start multipathd at init time.
85 #
86 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)};then
87 install -d ${D}${sysconfdir}/init.d
88 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
89 fi
90
Brad Bishop0e2770c2020-01-21 07:31:46 -050091 sed -i "s:/usr/lib/udev/kpartx_id:${nonarch_base_libdir}/udev/kpartx_id:g" \
92 ${D}${nonarch_base_libdir}/udev/rules.d/11-dm-mpath.rules
93
Brad Bishop19323692019-04-05 15:28:33 -040094 install -d ${D}${sysconfdir}
95 install -m 0644 ${WORKDIR}/multipath.conf.example \
96 ${D}${sysconfdir}/multipath.conf.example
97}
98
99FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
100
101PACKAGES =+ "${PN}-libs"
102FILES_${PN}-libs = "${base_libdir}/lib*.so.* \
103 ${base_libdir}/multipath/lib*.so*"
104RDEPENDS_${PN} += "${PN}-libs bash"
105
106PROVIDES += "device-mapper-multipath"
107RPROVIDES_${PN} += "device-mapper-multipath"
108RPROVIDES_${PN}-libs += "device-mapper-multipath-libs"
109
110FILES_${PN}-dev += "${base_libdir}/pkgconfig"
111
112PACKAGES =+ "kpartx"
113FILES_kpartx = "${base_sbindir}/kpartx \
Brad Bishop0e2770c2020-01-21 07:31:46 -0500114 ${nonarch_base_libdir}/udev/kpartx_id \
Brad Bishop19323692019-04-05 15:28:33 -0400115 "
116
Brad Bishop0f291cc2019-09-01 15:16:57 -0400117RDEPENDS_${PN} += "kpartx"