blob: 1510a0ef4f73c83013112bbcc836e86680cc0ae1 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require avahi.inc
2
Brad Bishop6dbb3162019-11-25 09:41:34 -05003inherit features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -04004ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
5
Brad Bishop316dfdd2018-06-25 12:45:53 -04006DEPENDS += "avahi"
7
8AVAHI_GTK = "gtk3"
9
10S = "${WORKDIR}/avahi-${PV}"
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012PACKAGES += "${PN}-utils avahi-discover"
Brad Bishop316dfdd2018-06-25 12:45:53 -040013
14FILES_${PN} = "${libdir}/libavahi-ui*.so.*"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015FILES_${PN}-utils = "${bindir}/b* ${datadir}/applications/b*"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016FILES_avahi-discover = "${datadir}/applications/avahi-discover.desktop \
17 ${datadir}/avahi/interfaces/avahi-discover.ui \
18 ${bindir}/avahi-discover-standalone \
19 "
20
21do_install_append () {
22 rm ${D}${sysconfdir} -rf
Brad Bishop79641f22019-09-10 07:20:22 -040023 if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
24 if [ "${nonarch_base_libdir}" != "${base_libdir}" ];then
25 rm ${D}${nonarch_base_libdir} -rf
26 fi
27 else
28 rm ${D}${base_libdir} -rf
29 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040030 rm ${D}${systemd_unitdir} -rf
31 # The ${systemd_unitdir} is /lib/systemd, so we need rmdir /lib,
32 # but not ${base_libdir} here. And the /lib may not exist
33 # whithout systemd.
34 [ ! -d ${D}/lib ] || rmdir ${D}/lib --ignore-fail-on-non-empty
35 rm ${D}${bindir}/avahi-b*
36 rm ${D}${bindir}/avahi-p*
37 rm ${D}${bindir}/avahi-r*
38 rm ${D}${bindir}/avahi-s*
39 rm ${D}${includedir}/avahi-c* -rf
40 rm ${D}${includedir}/avahi-g* -rf
41 rm ${D}${libdir}/libavahi-c*
42 rm ${D}${libdir}/libavahi-g*
43 rm ${D}${libdir}/pkgconfig/avahi-c*
44 rm ${D}${libdir}/pkgconfig/avahi-g*
45 rm ${D}${sbindir} -rf
46 rm ${D}${datadir}/avahi/a*
47 rm ${D}${datadir}/locale/ -rf
48 rm ${D}${datadir}/dbus* -rf
49 rm ${D}${mandir}/man1/a*
50 rm ${D}${mandir}/man5 -rf
51 rm ${D}${mandir}/man8 -rf
52 rm ${D}${libdir}/girepository-1.0/ -rf
53 rm ${D}${datadir}/gir-1.0/ -rf
54}