blob: 48fc0c4a7695b77ba4294191c60a2c138cdb4817 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Live image install script for grub"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init-install.sh"
5
6PR = "r9"
7
8S = "${WORKDIR}"
9
Brad Bishop316dfdd2018-06-25 12:45:53 -040010RDEPENDS_${PN} = "grub parted e2fsprogs-mke2fs util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
13do_install() {
14 install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh
15}
16
17# While this package maybe an allarch due to it being a
18# simple script, reality is that it is Host specific based
19# on the COMPATIBLE_HOST below, which needs to take precedence
20#inherit allarch
21INHIBIT_DEFAULT_DEPS = "1"
22
23FILES_${PN} = " /install.sh "
24
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025COMPATIBLE_HOST = "(i.86.*|x86_64.*|aarch64.*)-linux"