blob: 4750de8be0bbcb97845ad081ff1349b573fc08a4 [file] [log] [blame]
Jie Yang7fe1bad2021-08-06 12:41:16 -07001SUMMARY = "GLOME Login Client"
2DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9inherit meson pkgconfig
10
11DEPENDS += " \
12 openssl \
13 glib-2.0 \
14 "
15
16S = "${WORKDIR}/git"
17SRC_URI = "git://github.com/google/glome.git"
18SRCREV = "b7084b5c60682a0b4f4ae3f2ec6048e65212c377"
19
20FILES_${PN} += "${libdir}/security"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
24PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
25
26EXTRA_OEMESON = "-Dtests=disabled"