blob: 29107638638c0953e258723b0969a83b2f4e24ce [file] [log] [blame]
Brad Bishop2ad7ce32017-07-09 23:41:49 -04001# Common code for recipes that modify the phosphor-mapper
2# configuration.
3#
4# Typically it is not desired to monitor all dbus traffic
5# on a system and as such, the phosphor-mapper has command
6# line options to control what path namespaces and dbus
7# interfaces it will keep track of.
8#
9# The Phosphor layer by default configures the mapper to
10# watch xyz.openbmc_project interfaces and paths only. This
11# configuration file is intended to be inherited by
12# native recipes in other layers that wish to add namespaces
13# or interfaces to the mapper watchlist.
14
15# Add path namespaces to be monitored:
16# PHOSPHOR_MAPPER_NAMESPACE_append = " /foo/bar"
17
18# Add interfaces to be monitored:
19# PHOSPHOR_MAPPER_INTERFACE_append = " foo.bar"
20
21# Blacklist paths from being monitored:
22# PHOSPHOR_MAPPER_NAMESPACE_BLACKLIST_append = " /foo/bar/baz"
23
24# Blacklist interfaces from being monitored:
25# PHOSPHOR_MAPPER_INTERFACE_BLACKLIST_append = " foo.bar.baz"
26
27inherit phosphor-mapperdir
Brad Bishop02f9a522018-03-09 16:51:57 -050028inherit obmc-phosphor-utils
Brad Bishop2ad7ce32017-07-09 23:41:49 -040029
30python phosphor_mapper_do_postinst() {
31 def process_var(d, var, dir):
32 for p in listvar_to_list(d, var):
33 parent = d.getVar('D', True) + d.getVar(dir, True)
34 if not os.path.exists(parent):
35 os.makedirs(parent)
36 path = os.path.join(
37 parent,
Brad Bishop9b3beee2017-08-03 15:56:09 -040038 '-'.join(p.split(os.sep)))
Brad Bishop2ad7ce32017-07-09 23:41:49 -040039 with open(path, 'w+') as fd:
40 pass
41
42 process_var(d, 'PHOSPHOR_MAPPER_NAMESPACE', 'namespace_dir')
43 process_var(d, 'PHOSPHOR_MAPPER_INTERFACE', 'interface_dir')
44 process_var(d, 'PHOSPHOR_MAPPER_NAMESPACE_BLACKLIST', 'blacklist_dir')
45 process_var(
46 d, 'PHOSPHOR_MAPPER_INTERFACE_BLACKLIST', 'interfaceblacklist_dir')
47}
48
49do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACE"
50do_install[vardeps] += "PHOSPHOR_MAPPER_INTERFACE"
51do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACE_BLACKLIST"
52do_install[vardeps] += "PHOSPHOR_MAPPER_INTERFACE_BLACKLIST"
53do_install[postfuncs] += "phosphor_mapper_do_postinst"