blob: a539148caf04942c01ce5eb41ffea2cb95c72522 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library containing NIS functions using TI-RPC (IPv6 enabled)"
5DESCRIPTION = "This library contains the public client interface for NIS(YP) and NIS+\
6 it was part of glibc and now is standalone packages. it also supports IPv6"
7HOMEPAGE = "https://github.com/thkukuk/libnsl"
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10SECTION = "libs"
11DEPENDS = "libtirpc"
12DEPENDS_append_libc-musl = " bsd-headers"
13
14PV = "1.0.5+git${SRCPV}"
15
16SRCREV = "dfa2f313524aff9243c4d8ce1bace73786478356"
17
18SRC_URI = "git://github.com/thkukuk/libnsl \
19 file://0001-include-sys-cdefs.h-explicitly.patch \
20 file://0002-Define-glibc-specific-macros.patch \
21 file://0001-nis_call.c-Include-stdint.h-for-uintptr_t-definition.patch \
22 "
23
24S = "${WORKDIR}/git"
25
26inherit autotools pkgconfig gettext
27
28EXTRA_OECONF += "--libdir=${libdir}/nsl --includedir=${includedir}/nsl"
29
30do_install_append() {
31 install -d ${D}${libdir}
32 mv ${D}${libdir}/nsl/pkgconfig ${D}${libdir}
33}
34
35FILES_${PN} += "${libdir}/nsl/*.so.*"
36FILES_${PN}-dev += "${includedir}/nsl ${libdir}/nsl/*.so"
37FILES_${PN}-staticdev += "${libdir}/nsl/*.a"