blob: b331c361e3c3a6acc3bd855a01c435172a5462f2 [file] [log] [blame]
Andrew Geissler9347dd42023-03-03 12:38:41 -06001# Install EDK2 Base Tools in native sysroot. Currently the BaseTools are not
2# built, they are just copied to native sysroot. This is sufficient for
3# generating UEFI capsules as it only depends on some python scripts. Other
4# tools need to be built first before adding to sysroot.
5
6SUMMARY = "EDK2 Base Tools"
7LICENSE = "BSD-2-Clause-Patent"
8
9# EDK2
10SRC_URI = "git://github.com/tianocore/edk2.git;branch=master;protocol=https"
11LIC_FILES_CHKSUM = "file://License.txt;md5=2b415520383f7964e96700ae12b4570a"
12
Andrew Geissler80d41842023-09-11 08:36:15 -040013SRCREV = "f80f052277c88a67c55e107b550f504eeea947d3"
Andrew Geissler9347dd42023-03-03 12:38:41 -060014
15S = "${WORKDIR}/git"
16
17inherit native
18
19RDEPENDS:${PN} += "python3-core"
20
21do_install () {
22 mkdir -p ${D}${bindir}/edk2-BaseTools
23 cp -r ${WORKDIR}/git/BaseTools/* ${D}${bindir}/edk2-BaseTools/
24}