blob: dbe9355374c45362694c4b55d01d324e0c9b26e3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Javascript bindings for GNOME"
2LICENSE = "MIT & LGPLv2+"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
5 file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
6"
7
8GNOMEBASEBUILDCLASS = "autotools"
9
10DEPENDS = "mozjs gtk+3"
11
12inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even
13
14SRC_URI[archive.md5sum] = "7f671b3fc3b149adce263495540e7f50"
15SRC_URI[archive.sha256sum] = "1864bf22f4f5e4107832b4c54127cce8509d37ccc14abd25a6878c7ffed96640"
16SRC_URI += "file://0001-Disable-tests-on-host.patch"
17
18# gobject-introspection is mandatory and cannot be configured
19REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
20UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
21
22EXTRA_OECONF = " \
23 --without-dbus-tests \
24 --disable-installed-tests \
25"
26
27do_configure_prepend() {
28 # make configure find gobject-introspection test code. Although we set
29 # --disable-installed-tests gjs builds them
30 sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
31}
32
33FILES_${PN} += "${datadir}/gjs-1.0/lsan"
34
35PACKAGES =+ "${PN}-valgrind"
36FILES_${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
37RSEPENDS_${PN}-valgrind += "valgrind"