blob: 00b89dad5d8b8c793bea94e77151fe7771c63c49 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Window and compositing manager based on Clutter"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = " \
6 xserver-xorg-cvt-native \
7 virtual/libx11 \
8 gtk+3 \
9 gdk-pixbuf \
10 cairo \
11 pango \
12 gsettings-desktop-schemas \
13 json-glib \
14 gnome-desktop3 \
15 gnome-settings-daemon \
16 libxtst \
17 libxkbfile \
18 xinerama \
19"
20
21GNOMEBASEBUILDCLASS = "meson"
22
23inherit gnomebase gsettings gobject-introspection gettext upstream-version-is-even features_check
24
25SRC_URI[archive.md5sum] = "4a16dad1d93d5e1f81d555da35faf0e9"
26SRC_URI[archive.sha256sum] = "d1d149b70ed7330771f4524886b98775fce5a11cf17f9683cba151075f2879c4"
27SRC_URI += "file://0001-EGL-Include-EGL-eglmesaext.h.patch"
28
29# x11 is still manadatory - see meson.build
30REQUIRED_DISTRO_FEATURES = "x11"
31
32# systemd can be replaced by libelogind (not available atow - make systemd
33# mandatory distro feature)
34LOGIND ?= "systemd"
35REQUIRED_DISTRO_FEATURES += "systemd"
36
37# profiler requires sysprof 3.34 which is not willing to build atow
38PACKAGECONFIG ??= " \
39 native-backend \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl glx', '', d)} \
41 sm \
42 startup-notification \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl wayland', 'wayland', '', d)} \
44"
45
46EXTRA_OEMESON += " \
47 -Dxwayland_path=${bindir}/Xwayland \
48"
49
50# combi-config - see meson_options.txt for more details
51PACKAGECONFIG[native-backend] = "-Dnative_backend=true -Dudev=true, -Dnative_backend=false -Dudev=false, libdrm virtual/libgbm libinput ${LOGIND} virtual/egl virtual/libgles2 udev"
52PACKAGECONFIG[opengl] = "-Dopengl=true, -Dopengl=true, virtual/libgl"
53PACKAGECONFIG[glx] = "-Dglx=true, -Dglx=false"
54PACKAGECONFIG[libwacom] = "-Dlibwacom=true, -Dlibwacom=false, libwacom"
55PACKAGECONFIG[remote-desktop] = "-Dremote_desktop=true, -Dremote_desktop=false, pipewire-0.2"
56PACKAGECONFIG[sm] = "-Dsm=true, -Dsm=false, libsm"
57PACKAGECONFIG[profiler] = "-Dprofiler=true,-Dprofiler=false,sysprof"
58PACKAGECONFIG[startup-notification] = "-Dstartup_notification=true, -Dstartup_notification=false, startup-notification, startup-notification"
59PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland wayland-native, xserver-xorg-xwayland"
60PACKAGECONFIG[wayland-eglstream] = "-Dwayland_eglstream=true,-Dwayland_eglstream=false"
61
62# yes they changed from mutter-4 -> mutter-5 recently so be perpared
63MUTTER_API_NAME = "mutter-5"
64
65do_install_append() {
66 # Add gir links in standard paths. That makes dependents life much easier
67 # to find them
68 install -d ${D}${datadir}/gir-1.0
69 for gir_full in `find ${D}${libdir}/${MUTTER_API_NAME} -name '*.gir'`; do
70 gir=`basename "$gir_full"`
71 ln -sr "${D}${libdir}/${MUTTER_API_NAME}/$gir" "${D}${datadir}/gir-1.0/$gir"
72 done
73}
74
75PACKAGES =+ "${PN}-tests"
76
77FILES_${PN} += " \
78 ${datadir}/gnome-control-center \
79 ${libdir}/${MUTTER_API_NAME}/lib*${SOLIBS} \
80 ${libdir}/${MUTTER_API_NAME}/*.typelib \
81 ${libdir}/${MUTTER_API_NAME}/plugins \
82"
83
84FILES_${PN}-tests += " \
85 ${datadir}/installed-tests \
86 ${datadir}/${MUTTER_API_NAME}/tests \
87 ${libexecdir}/installed-tests/${MUTTER_API_NAME} \
88"
89
90FILES_${PN}-dev += " \
91 ${libdir}/${MUTTER_API_NAME}/*.gir \
92 ${libdir}/${MUTTER_API_NAME}/lib*.so \
93"
94
95RDEPENDS_${PN} += "zenity"
96