blob: c3dcd2b8213e189a76d2a6dc2c3ac27ae43c6ebc [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# Simple initramfs image. Mostly used for live images.
2DESCRIPTION = "Small image capable of booting a device. The kernel includes \
3the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \
4to check the hardware efficiently."
5
6PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
7
8# Do not pollute the initrd image with rootfs features
9IMAGE_FEATURES = ""
10
11export IMAGE_BASENAME = "initramfs-debug-image"
12IMAGE_LINGUAS = ""
13
14IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
15inherit core-image
16
17IMAGE_ROOTFS_SIZE = "8192"
18IMAGE_ROOTFS_EXTRA_SPACE = "0"
19
20BAD_RECOMMENDATIONS += "busybox-syslog"