blob: 5b57abb87ab29a3136edb958e6c71589d903d9fa [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl bison-native \
7 ${@bb.utils.contains('PACKAGECONFIG', 'mini-gmp', '', 'gmp', d)}"
8
9# Ensure we reject the 0.099 version by matching at least two dots
10UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
11
12SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
13SRC_URI[md5sum] = "fdfd51a1083fb054a487b5159b1ed5cd"
14SRC_URI[sha256sum] = "08b8683a9db5fba980bc092b75288af98d218bbe8ab446daf2338570d0730f9a"
15
16inherit autotools manpages pkgconfig
17
18PACKAGECONFIG ??= "python readline"
19PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
20PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
21PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
22PACKAGECONFIG[python] = "--enable-python --with-python-bin=${PYTHON}, --with-python-bin="", python3"
23PACKAGECONFIG[readline] = "--with-cli=readline, --without-cli, readline"
24PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
25
26inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
27
28RRECOMMENDS_${PN} += "kernel-module-nf-tables"
29
30PACKAGES =+ "${PN}-python"
31FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
32RDEPENDS_${PN}-python = "python3-core python3-json"