blob: 73199592c889ec73de8a0ae73849141f3cd2282e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require wireguard.inc
2
3SRCREV = "43f57dac7b8305024f83addc533c9eede6509129"
4
5SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat"
6
7inherit module kernel-module-split
8
9DEPENDS = "virtual/kernel libmnl"
10
11# This module requires Linux 3.10 higher and several networking related
12# configuration options. For exact kernel requirements visit:
13# https://www.wireguard.io/install/#kernel-requirements
14
15EXTRA_OEMAKE_append = " \
16 KERNELDIR=${STAGING_KERNEL_DIR} \
17 "
18
19MAKE_TARGETS = "module"
20
21RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
22MODULE_NAME = "wireguard"
23
24# Kernel module packages MUST begin with 'kernel-module-', otherwise
25# multilib image generation can fail.
26#
27# The following line is only necessary if the recipe name does not begin
28# with kernel-module-.
29PKG_${PN} = "kernel-module-${MODULE_NAME}"
30
31module_do_install() {
32 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
33 install -m 0644 ${MODULE_NAME}.ko \
34 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
35}